Supported Devices

In order to connect with the TDI stylus and play Golem Arcana, your phone or tablet must support Bluetooth 4 LE (Low Energy). Below is a list of devices currently supported by Golem Arcana.

iOS:

  • iPhone 4s/5/5s/5c/6/6 Plus
  • iPad (3rd & 4th gen)
  • iPad Air
  • iPad Mini (2nd Generation)
  • iPod Touch (5th Generation)

Android:

Version 4.3 – 5.1.1 on a device that supports Bluetooth 4.0 (LE); devices tested include:

  • Google
    • Nexus 4/5/6
    • Nexus 7 (2013)
    • Nexus 9
  • Samsung
    • Galaxy S3/S5 /S6
    • GalaxyTab 4/S /Pro
    • GalaxyTab 4 NOOK 7.0/10.0
    • Note 3
  • HTC
    • One M7 (4.3+)
    • One M8/Max (4.3+)
  • Dell
    • Venue 8 (Android)
  • Sony
    • Xperia Series

Amazon:

  • Fire HD X 8.9 (4th Generation)
  • Fire HD 7 (4th Generation)
  • Fire HD 6 (4th Generation)

Play Golem Arcana on your TV! – Works great with a compatible device and Chromecast or Apple TV

 

Download App